Technical Discussion Topics related to Technical Issues

Turn Signal woes...Right side won't blink

Old 05-06-2013, 10:42 AM
  #1  
Senior Member
SuperSport
Thread Starter
 
98VTRrider's Avatar
 
Join Date: Jun 2010
Location: Baltimore, Maryland
Posts: 636
98VTRrider is on a distinguished road
Turn Signal woes...Right side won't blink

I just finished rebuilding a salvage title bike I got, and now I'm trying to get things all finished for my police inspection.

Last week I had everything working fine, both sides would blink as they should...

Then I made some brackets to hold the front signals(one piece upper fairing I didn't want to cut).

Now I'm having problems, the left side blinks ok, but the right side when I push the turn control right, the front right signal(which stays lit when not using blinker function) goes out, but neither front or rear lights blink.

I've swapped turn signal relays and that didn't help.

I've checked all the bulbs, they are all good, the right wattage.

I brought another light up and hooked it to the right front wires, still no blinking.

I really don't want to pull the fairing off again but I guess I'll have to to check all the plugs under/behind the gauge cluster...

I've done most test with the motor running for full voltage, but today I put a 2amp charger on to test without the motor running...Left blink works ok...no right blink.


Any other ideas of things I should check or look at?
98VTRrider is offline  
Old 05-06-2013, 10:52 AM
  #2  
Senior Member
MotoGP
 
7moore7's Avatar
 
Join Date: Jul 2010
Location: Phoenix, AZ
Posts: 3,867
7moore7 is on a distinguished road
There are three wires to the signals. A green one (ground) and a solid color and striped color. I believe it is your striped color (slight possibility that it is the solid) that is not making a connection somewhere. Trace the wire and figure out where.
7moore7 is offline  
Old 05-06-2013, 08:26 PM
  #3  
Senior Member
SuperSport
Thread Starter
 
98VTRrider's Avatar
 
Join Date: Jun 2010
Location: Baltimore, Maryland
Posts: 636
98VTRrider is on a distinguished road
Originally Posted by 7moore7 View Post
There are three wires to the signals. A green one (ground) and a solid color and striped color. I believe it is your striped color (slight possibility that it is the solid) that is not making a connection somewhere. Trace the wire and figure out where.
Yea that's what it needs.. Drives me nuts when it was working at one point, then I put the fairing on and it stops working...something must have been pulled on too hard or something like that when I was rerouting the wires.
98VTRrider is offline  
Old 05-09-2013, 10:52 AM
  #4  
Senior Member
SuperSport
Thread Starter
 
98VTRrider's Avatar
 
Join Date: Jun 2010
Location: Baltimore, Maryland
Posts: 636
98VTRrider is on a distinguished road
More confusion today...I pulled the fairing off..All the wires were good looking into the main harness.

The only thing I did was open the fuse box, and swap the 10amp turn signal fuse with another 10A from the odometer.

I turned the key on, and the right side started blinking, I must have left the switch set to "right turn".

Now, If I switch to the left, the left side starts blinking, but when I then switch to the right, the front light goes out, then about 5-10 seconds later the right side starts to blink, some times it will blink/flash 3-4 times REALLY FAST, then slow down to a normal blink speed.

Seems kinda intermittent too... sometimes it will do the fast flash thing at first, some times it just takes a few extra seconds to start blinking.

Is there anything else I can change or check that might make a difference to the speed it takes to start blinking? Do I just have a slight resistance build up at the several connections for the signals? An old turn signal relay wearing out?(I have two that produce the same results)
98VTRrider is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Gabe
Technical Discussion
6
03-19-2015 10:10 AM
Myhairym0nk3y
Modifications - Cosmetic
5
01-19-2014 09:03 AM
SlowHAWK
General Discussion
6
03-17-2005 10:01 AM


Thread Tools
Search this Thread
Quick Reply: Turn Signal woes...Right side won't blink


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.