Technical Discussion Topics related to Technical Issues

Speedo acting strange

Old 09-09-2011, 08:28 PM
  #1  
Senior Member
Back Marker
Thread Starter
 
20_rc51_00's Avatar
 
Join Date: Jul 2010
Posts: 218
20_rc51_00 is on a distinguished road
Speedo acting strange

So today after 3 wks of the bike sitting I take it for a spin and notice that the speedo goes nuts up and down randomly while at a stand still. The bike has a speedo healer but was working normally before.

I'm thinking that I will try and charge the battery and then disconnect the healer and see if it resolves it. the bike is a 98 with analog gauges.

anyone ever have this happen?
20_rc51_00 is offline  
Old 09-09-2011, 08:38 PM
  #2  
Senior Member
MotoGP
 
superhawk22's Avatar
 
Join Date: Jan 2005
Location: Gainesville FLA.
Posts: 3,844
superhawk22 is an unknown quantity at this point
Had it happen once with my '98 when the regulator/rectifier went bad. check the connector for burnt wires and or a burnt spot on the R/R, very common problem, I ended up using an R1 R/R after the 2nd one went bad.
superhawk22 is offline  
Old 09-09-2011, 08:43 PM
  #3  
Senior Member
Back Marker
Thread Starter
 
20_rc51_00's Avatar
 
Join Date: Jul 2010
Posts: 218
20_rc51_00 is on a distinguished road
haha lol if that's the case then it will be about time I put the new one in. I also have a R1 type r/r ready to go. If this is the case i'm lucky the bike didn't crap out while I was far from home...
20_rc51_00 is offline  
Old 09-09-2011, 08:52 PM
  #4  
Senior Member
MotoGP
 
superhawk22's Avatar
 
Join Date: Jan 2005
Location: Gainesville FLA.
Posts: 3,844
superhawk22 is an unknown quantity at this point
Yep damn lucky I had to jump start mine 4 or 5 times to get home, about a 12 mile trip!
superhawk22 is offline  
Old 09-11-2011, 07:33 PM
  #5  
Senior Member
Back Marker
Thread Starter
 
20_rc51_00's Avatar
 
Join Date: Jul 2010
Posts: 218
20_rc51_00 is on a distinguished road
go the rr replaced and mounted some new tires aswell. No more funny speedo action. Thanks. (but I think it really was the tires )
20_rc51_00 is offline  
Old 09-13-2011, 09:02 PM
  #6  
Senior Member
MotoGP
 
superhawk22's Avatar
 
Join Date: Jan 2005
Location: Gainesville FLA.
Posts: 3,844
superhawk22 is an unknown quantity at this point
No problem, glad the tires worked out for ya!
superhawk22 is offline  
Old 09-17-2011, 06:31 PM
  #7  
Senior Member
Back Marker
Thread Starter
 
20_rc51_00's Avatar
 
Join Date: Jul 2010
Posts: 218
20_rc51_00 is on a distinguished road
well the speedometer is acting weird again. it bounces all around when the bike is not moving and when it is in motion the speedo is a bit jittery. I replaced the RR last week and the voltages etc are all in spec. any ideas what else could be the matter? THanks.
20_rc51_00 is offline  
Old 09-17-2011, 06:50 PM
  #8  
Senior Member
SuperSport
 
thetophatflash's Avatar
 
Join Date: Jan 2005
Location: Nooksack WA
Posts: 831
thetophatflash
load test the battery?
thetophatflash is offline  
Old 09-18-2011, 01:35 AM
  #9  
Senior Member
SuperBike
 
Wicky's Avatar
 
Join Date: Sep 2008
Location: Essex, UK
Posts: 1,632
Wicky is on a distinguished road
The Speedo Sensor can start acting weirdly when it fails. Check connections from where it goes in rear pot next to CCT, and to where it plugs into loom.
Wicky is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Little_Horse
Technical Discussion
15
05-17-2008 01:46 AM
loserbaby
Technical Discussion
26
09-21-2007 10:36 PM
hazzy
Technical Discussion
2
08-26-2007 07:50 PM
nova_scotian_996
Technical Discussion
8
04-25-2007 02:58 AM
call me phil
General Discussion
3
05-17-2005 05:49 AM


Thread Tools
Search this Thread
Quick Reply: Speedo acting strange


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.