General Discussion Anything SuperHawk Related

VTR idles but no power to the cluster

Old 03-26-2018, 04:28 PM
  #1  
Junior Member
Squid
Thread Starter
 
Join Date: Mar 2018
Posts: 1
paulcmoore is on a distinguished road
VTR idles but no power to the cluster

Hey all.
Riding yesterday and the bikes tach just stopped and the bike lost power. This is electrical for sure. The bike will idle perfectly, but when I try to twist the throttle, it wont rev past 2 thousand and backfire. Periodically, the tach starts to work again, and all power is back, including reving fine. It wont stay though, the tach goes to zero and if wont run off idle.
Thoughts?
paulcmoore is offline  
Old 03-26-2018, 06:07 PM
  #2  
Senior Member
Back Marker
 
Join Date: Apr 2017
Location: Cali High Desert
Posts: 108
AlanS is on a distinguished road
Regulator (do you have the stock unit?), battery, alternator. I'd verify them in that order, along with their connections to the system. Could be an intermittent 'open' elsewhere, too. But I'd check these first. Probably not much more than you'd have done, anyway.

Alan
AlanS is offline  
Old 03-27-2018, 05:16 AM
  #3  
Moderator
MotoGP
 
Wolverine's Avatar
 
Join Date: Jul 2007
Location: Gettysburg, Pa
Posts: 4,446
Wolverine is on a distinguished road
I'd definitely do the mosfet R/R swap if it hasn't been done already. Look at the condition of the wires going into the r/r plug itself. A lot of times they will show signs for over heating. Use dielectric grease on connectors, check all ground connections etc.
Wolverine is offline  
Old 03-27-2018, 01:42 PM
  #4  
VTR virgin
Superstock
 
Cadbury64's Avatar
 
Join Date: Mar 2015
Location: Auckland, New Zealand
Posts: 405
Cadbury64 is on a distinguished road
If it were mine I'd check the battery voltage when running (looking for something over 13V), and if that is OK then I'd start looking for a bad/corroded/loose electrical connection, e.g. battery terminals or earth connection to frame, or the 30A main fuse.
Cadbury64 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
E.Marquez
Everything Else
4
04-12-2013 05:24 PM
SPEED DEMON1322
Technical Discussion
10
03-11-2013 04:45 AM
sdhawkrider
Knowledge Base
15
09-24-2012 04:04 PM
99superhawk_Dom
Technical Discussion
12
08-15-2012 08:31 AM
stangy89
General Discussion
18
05-20-2012 11:30 AM


Thread Tools
Search this Thread
Quick Reply: VTR idles but no power to the cluster


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.

All times are GMT -7. The time now is 03:16 PM.


© 2019 MH Sub I, LLC dba Internet Brands