Technical Discussion Topics related to Technical Issues

Speedo Issue/Neutral light issue

Old 03-25-2018, 12:45 PM
  #1  
Junior Member
Squid
Thread Starter
 
Jake2345's Avatar
 
Join Date: May 2017
Posts: 21
Jake2345 is on a distinguished road
Speedo Issue/Neutral light issue

hey guys
For a little while now ive been having a issue with my SH were i'll shift into 3rd or 4th gear and as soon as i start too accelerate the speedo goes start to zero. I've heard that it could be electrical but any ideas on what it could possible be? Also I have a issue were if i'm idling at a light and i go into neutral my neutral light doesnt come on, it also kills the bike, could my neutral safety switch be going? (I think thats what it is called)
Cheers
P.S.
has anybody done a full rebuild on one of these before? Is it worth doing or no?
Jake2345 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Peeb
Technical Discussion
5
04-14-2017 08:22 AM
waltr
Technical Discussion
9
09-23-2016 10:27 AM
Apocalypse
Technical Discussion
3
03-08-2015 07:18 PM
VTR
Technical Discussion
17
05-29-2014 03:31 PM
Hayai
Technical Discussion
1
12-11-2011 05:23 PM


Thread Tools
Search this Thread
Quick Reply: Speedo Issue/Neutral light issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.