Technical Discussion Topics related to Technical Issues

Electrical/wont start!!

Old 07-24-2007, 12:01 AM
  #1  
Member
Squid
Thread Starter
 
Join Date: Nov 2005
Location: Bellevue, NE
Posts: 67
USAFrider
Electrical/wont start!!

I know this has been addressed before about the r/r but I want to get input.
2 weeks ago my bike wouldn't start right after a ride so I jumped it and it ran fine until tonight. I left work, drove 1 mile to the gas station, filled up and there is absolutely no power. With the key on I get nothing, no lights, gauges or electrical power of any sort. Completely dead and it will not jump. I hooked up jumpers to the battery just like last time and I get no hint of light. If it is the r/r, does any one have a working one for sale cheap? I have to sell the bike this week for my divorce! Are there regulator rectifiers that will work from other bikes that might be cheaper new?
USAFrider is offline  
Old 07-24-2007, 05:02 AM
  #2  
Senior Member
Back Marker
 
StoneJrW's Avatar
 
Join Date: Feb 2007
Location: Shelbyville, KY
Posts: 204
StoneJrW is on a distinguished road
Mine went dead just like yours and I found out the I had blown the 30 amp fuse under the tail fairing on the left side.

I used a r/r from a 04 gsxr that I got on ebay for 30 bucks.
StoneJrW is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mr.Lojo
Technical Discussion
8
02-07-2015 02:48 PM
Nu2thahawk
Technical Discussion
11
09-18-2007 12:48 PM
ali_squidz
Technical Discussion
48
04-07-2007 05:57 PM
Tonyzz
Technical Discussion
5
03-29-2006 01:20 PM
Shmittay
Technical Discussion
5
11-03-2004 04:11 AM


Thread Tools
Search this Thread
Quick Reply: Electrical/wont start!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.