Technical Discussion Topics related to Technical Issues

reg/rectifier

Old 07-25-2005, 02:09 PM
  #1  
Junior Member
Squid
Thread Starter
 
Join Date: Jul 2005
Location: chicago (wicker park)
Posts: 11
standzchop
reg/rectifier

hello...i'm new to this site. i just picked up my first 98'superhawk...the three wires coming out of the alt. were cut... it looks like they clipped a connector out of the loom...i respliced the three yellow wires and one yellow/blue stripe wire.....my problem is this.....when connecting the battery i'm getting a big blue spark at the neg post..as if something is drawing a strong current...even though the ign. is off. so i disconnected the reg/rectifier cause it was getting hot.......now there isn't a draw at the battery.....my question is this... can a reg/rectfier go bad and cause a draw even though the ign. is off??? ...............or did i connect something wrong????thnx in advance for the help....standzchop
standzchop is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Montana
Technical Discussion
8
10-09-2012 05:40 PM
thefauxnarchist
Classifieds
4
10-06-2008 04:04 PM
F1 Fan in Nascar Land
Classifieds
0
03-27-2008 12:26 PM
redman
Modifications - Performance
1
07-24-2007 10:16 PM
Redhawk996
Technical Discussion
1
07-21-2004 02:09 PM


Thread Tools
Search this Thread
Quick Reply: reg/rectifier


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.